SAP Knowledge Base Article - Public

3410887 - Removing an Analytics Hub Role throws a license error in SAP Analytics Cloud (SAC)

Symptom

When trying to remove an Analytics Hub role from a user or team, you get the error:

'The maximum number of licenses have been reached. Please check your current license usage limits. Then deactivate users, delete inactive users, or consider an upgrade to your plan.'

This happens whether you try to remove the role via SAC application or with the SCIM API.

Environment

  • SAP Analytics Cloud (Enterprise) 2023.1.1

Reproducing the Issue

  1. Obtain SAC Hub license
  2. While License is active, assign a Hub role to a user or team
  3. Remove / have Hub license expire
  4. Attempt to remove Hub role from the user or team

Cause

Assigning or unassigning roles to users or teams triggers a license overage check.  If you have maxed out your license threshold you will fail the license overage enforcement.

Resolution

You will need to disable all users who have a role that uses a hub license.  Once all uses who have a hub license are disabled, you should be able to remove the role.

If the issue still persists please create a support case and reference this kbase so that support can follow the internal memo attached to this kbase.

See Also

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Keywords

license, hub, delete, inactive, assign , KBA , LOD-ANA-DES , Story Design & Visualizations , LOD-ANA-HUB , SAP Analytics Hub , Problem

Product

SAP Analytics Cloud 1.0