SAP Knowledge Base Article - Public

3411282 - Outbound File is Empty due to failed XI message: Field overflow: amount 100,000.000000 is too large for the target field (length 0008).

Symptom

You create an Outbound File XX but the file is empty due to the failed XI message in the Backend. ('XX' refers to Outbound File ID)

Error message:  Field overflow: amount 100,000.000000 is too large for the target field (length 0008).

   

Environment

SAP Business By Design.

Reproducing the Issue

1) Go to Liquidity Management work center.

2) Go to Outbound File XX. ('XX' refers to Outbound File ID)

3) Click the File ID and give view all.

4) The Outbound File is empty with no data.

Cause

This is due to the failed XI message from the backend. 

Technical Info might be:

Sender Party: PaymentProcessing 

Receiver Interface name: PaymentProcessingFileCreationForPaymentOrderingIn    

Error information: Field overflow: amount 100,000.000000 is too large for the target field (length 0008)

As per your Business Configuration settings, the length might be more or less than the amount shown in error message. Here the amount is being overfilled in the Outbound File, than its actual digits in the Business Configuration settings.

Resolution

Customer need to increase the field length for the amount and should save it. Please follow the below steps.

  1. Go to the Business Configuration work center
  2. Go to the Overview sub view.
  3. Search for the *Outgoing Bank Transfers* Activity.
  4. Click on Edit Payment File Structures.
  5. Select the File structure XYZ and click Edit ('XYZ' refers to File structure ID).
  6. Go to the step 3(Define fields).
  7. Under Fields, highlight the Amount.
  8. Here you can see the field length is 8.
  9. But the actual length of the Payment amount in the Outbound File is 12 digits (100,000.000000).
  10. You need to increase the field length for the amount and should save it.

Once the changes have done from your end, you need to create incident to Support. Then we will restart the failed XI message from the backend.  

If still the error persists you should create the new Outbound File after you performed the changes in Business Configuration.

See Also

https://launchpad.support.sap.com/#/notes/2716578

https://launchpad.support.sap.com/#/notes/3123906

Keywords

Outbound File, Field Overflow, Length, Outgoing Bank Transfers. , KBA , SRD-FIN-MOP , Payment Management , Problem

Product

SAP Business ByDesign 2311