SAP Knowledge Base Article - Public

3411698 - Change History of Transactional Data not available for some API endpoints.

Symptom

You have an ODATA API that can provide you with the Change History for the transactional data of Business Objects, for example Lead, Opportunity, Activity, Service Request etc.

However, you notice that the API is not working for example the Marketing Attribute and Customer Sales Territory data. 

Environment

SAP Cloud for Customer

Cause

Not all Business Objects are supported for API endpoints.

Resolution

In the documentation below, there is a list of Business Objects supported by the endpoint.  For example, Marketing Attribute and Customer Sales Territory is not supported.

https://help.sap.com/docs/SAP_CLOUD_FOR_CUSTOMER/1364b70b9cbb417ea5e2d80e966d4f49/abfca8fdb5694bd39d112498e5f6e539.html?q=change%20documents

Keywords

Change History, Transactional Data not available, supported business object, api endpoint , KBA , LOD-CRM-INT-API , OData API (C4C Only) , Problem

Product

SAP Cloud for Customer core applications all versions