Symptom
The time token [[INTERVIEW_TIME]] does not display correctly for the candidate in an interview email leaving no time or no time-zone present.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Go to Recruiting
- Select Interview Scheduling
- Select a candidate for an interview to schedule or send reminder email
- Schedule the candidate for an interview
- Select the language of the template as one of the below:
- Čeština (Czech)cs_CZ
- Lietuvių k (Lithuanian)lt_LT
- Magyar (Hungarian)hu_HU
- Norsk bokmål (Norwegian Bokmål)nb_NO
- Polski (Polish)pl_PL
- For the email pop up (Contact Candidates) ensure the token [[INTERVIEW_TIME]] is configured in the template
- Send the email
- Note the [[INTERVIEW_TIME]] token is displayed incorrectly or not at all
Cause
Currently, while sending an email in above mentioned languages using a template in which [[INTERVIEW_TIME]] token is configured, then for all US specific time zones, the timezone value will be localized while the email is sent. But if timezone is something different than the US time zone, for example "Asia/Kuala_Lumpur", then due to absence to handling that timezone, code will not able to localize and as a result only time will be sent without timezone value.
1. Issue will happen for internal candidates when the selected language for sending the email (using some email template which contains [[INTERVIEW_TIME]] token) to internal candidate is any language among above mentioned 5 and timezone of the internal candidate is anything apart from US time zones for example "Asia/Kuala_Lumpur".
2. Issue will happen for external candidates when the selected language for sending the email(using some email template which contains [[INTERVIEW_TIME]] token) to external candidate is any language among above mentioned 5 and timezone, of the operator who is triggering this email to the external candidate, is anything apart from US time zones for example "Asia/Kuala_Lumpur".
Here US Specific time zone noted above:
"EST","US/Eastern","US/East-Indiana","US/Michigan","America/New_York","America/Indianapolis" "PST","US/Pacific","US/Pacific-New","America/Los_Angeles" "AKST","US/Alaska","America/Anchorage","America/Sitka" "HST","US/Aleutian","US/Hawaii","Pacific/Honolulu" "MST","US/Arizona","US/Mountain","America/Denver","America/Phoenix" "CST","US/Central","US/Indiana-Starke","America/Chicago" "US/Samoa" "AST","America/Halifax" "NST","America/St_Johns"
Resolution
This is deemed an enhancement request by engineering and product management as for the five languages below the timezone portion for the code involving the this token [[INTERVIEW_TIME]] is not in place and will require significant resources to address.
Affected Languages:
- Čeština (Czech)cs_CZ
- Lietuvių k (Lithuanian)lt_LT
- Magyar (Hungarian)hu_HU
- Norsk bokmål (Norwegian Bokmål)nb_NO
- Polski (Polish)pl_PL
This has been prioritised by engineering and product management to correct.
For now manually entered time and time zone will be required by users and the token removed.
This issue can be followed up with by your Account Owner (CSP) for updates with the following code: RCM-123278
Keywords
interview, time, zone, timezone, locale, candidate, schedule, central, email, missing, token , KBA , LOD-SF-RCM-IVW , Interview Central, Interviews, Scheduling etc , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Product Enhancement