Symptom
The Custom Data Collection Configuration is set differently than expected. It's not possible to trace the rule for the candidate (is not possible for external users).
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Log in to the instance.
- Go to "Manage Data."
- Select "Process Trigger" in the first box.
- Search for the candidate Process ID.
- Find the "customDataCollectionConfig."
- See that the configuration is different than expected.
Cause
The candidate information is matching with another criteria in the rule.
Resolution
- Go to BPE: Monitor Processes
- Filter searching for the Onboarding Process ID in the Variable (You can search informing onboardingProcessId=[candidate process id here] in the Variable
- Find the dataCollection.Onboarding2CustomDataCollection in the process definition ID
- Go to Variables in the bottom of the page
- Find the rules triggered to the candidate in this step
- Copy the rule name
- Check the conditions comparing with the candidate information
Following these steps you will be able to see the condition that trigger the candidate Data Collection Configuration
Keywords
Onboarding,obx,custom,data,colletion,config,manager,candidate,trigger,object,not,same,rule,config,process , KBA , LOD-SF-OBX-CDC , Custom Data Collection , Problem
Product
SAP SuccessFactors Onboarding all versions