SAP Knowledge Base Article - Public

3413334 - No Customer Invoice is Created From Point-Of-Sales Transactions

Symptom

You have created and released a POS sales transaction, in the document flow tab you are able to find the outbound delivery document but no customer invoice document.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Customer Invoicing work center.
  2. Go to the Point-of-Sale Transactions view.
  3. Select the Sales Transaction sub view.
  4. Open Sales Transaction ABC (ABC represents the Internal ID of the Sales Transaction).
  5. Go to the Document Flow tab, there is no Customer Invoice document created.

Cause

In POS sales transactions,  the financial documents are generated out of the POS sales transaction, no customer invoice documents are generated. 

You can find more information from help center documents:

Point-of-Sale Transaction Processing

https://help.sap.com/docs/SAP_BUSINESS_BYDESIGN/2754875d2d2a403f95e58a41a9c7d6de/2cecf566722d101493b9ef865d0d79bd.html?q=point%20of%20sales%20#process-flow

for sales transaction, If the sales transaction data is consistent, it is automatically released to Financial Management and Inventory Management.

Correct and Release a Sales Transaction

https://help.sap.com/docs/SAP_BUSINESS_BYDESIGN/2754875d2d2a403f95e58a41a9c7d6de/2d9393cf722d1014a13d929b7c1c3db9.html#result If you have released the sales transaction, if required, the system creates a goods and activity confirmation in Inventory Management to post the goods issue and creates a corresponding journal entry in Financial Management. To check whether Financial Management documents have been created, search for the sales transaction in the All Sales Transactions view, open the sales transaction, and check the Document Flow. 

Resolution

This is the designed system behavior.

Keywords

POS; Point-of-sales; Point Of Sales; no customer invoice. , KBA , SRD-CRM-SEO , Service Orders , Problem

Product

SAP Business ByDesign 2311 ; SAP Business ByDesign 2402