Symptom
The "Sales Order External ID" field, inside the Integration section under the Ticket Overview, was not showing any ID, even though the Ticket has an external Sales Order associated to it.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Create a Ticket
- Associate a Sales Order to it
- Go to Overview facet
- Find the 'Integration' section
- 'Sales Order External ID' is empty
Cause
The field "External Sales Order ID" inside the Ticket Overview (Integration section) is only shown when the Ticket is created from ECC Sales Orders (ECC Sales Order Work Center > Select Item > Create Ticket)
So if you create a Ticket, and then associate a Sales Order, the External Sales Order ID will be empty.
Resolution
Create a Ticket from an ECC Sales Order directly.
Keywords
External Sales Order ID, Ticket, ECC Sales Order , KBA , LOD-CRM-SRP , Service Request Processing , How To