Symptom
Appointment Categories are sorted alphabetically in C4C, but not in outlook add-in.
Environment
SAP Cloud for Customer.
Reproducing the Issue
- Open outlook server side add-in and check an Appointment.
- Go to category field and notice that the values are not alphabetically sorted as in C4C system.
Cause
We do not sort a category pick list for an Appointment on our side. Here is a GET request sample:
https://<tenant address>.crm.ondemand.com/sap/c4c/odata/v1/c4codataapi/AppointmentCategoryCollection?$select=Description,Code,Context&$top=9999&$filter=Context%20eq%20%2712%27&$format=json
Resolution
This is the expected system behavior.
Please access our Influence Portal and suggest an improvement in this scenario if you believe it could best serve your business purposes.
Keywords
Appointment; categories; sorted; alphabetically; C4C; outlook; server side; add-in. , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , Product Enhancement