Symptom
You are replicating master data from source system to C4C and 400 errors code are raised in the Message Monitoring.
Error details:
{
"code": "inbound-data-connector.132",
"message": "Failed to process the inbound message.",
"details": [
{
"code": "400",
"message": "{\"error\":{\"message\":\"Title 2 does not exist.\",\"code\":\"sap.crm.common.commonMessage.titleCodeValueDoesNotExist\",\"target\":\"{formOfAddress}\"}}"
}
]
Use Case example:
- Employee replication from Success Factors to Cloud for Customer, all the employee records went into error due to error in value mapping, settings were done but still received an error.
Environment
Cloud for Customer Version 2
Reproducing the Issue
- Go to User menu
- Go to Settings
- Go to All settings
- Settings integration
- Open Message Monitoring
Error Details:
{
"code": "inbound-data-connector.132",
"message": "Failed to process the inbound message.",
"details": [
{
"code": "400",
"message": "{\"error\":{\"message\":\"Title 2 does not exist.\",\"code\":\"sap.crm.common.commonMessage.titleCodeValueDoesNotExist\",\"target\":\"{XYZ}\"}}"
}
]
Cause
The Mapping Group maintained in Communication Config is different from the mapping group of Code List Name maintained in value mapping.
Resolution
Ensure the Mapping Group maintained in Communication Config is not different from the Mapping Group of Code List Name maintained in value mapping.
Otherwise, the inbound message might fail even if the value mapping is maintained. The retry of the message might also fail due to the same reason.
Mapping group in Communication Config - ABC
Mapping group of form of Address - ABC
Keywords
value mapping;400;sap.crm.md.integrationmetadataservice.entity;inbound-data-connector , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Problem