SAP Knowledge Base Article - Public

3414231 - Birth name alt 1 and birth name alt 2 are not visible in personal information porlet

Symptom

The birth name alt 1 and birth name alt 2 are not visible even if the fields are enabled in Manage Business Configuration under "personalInfo" element.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors Employee Central all versions 
  • SAP SuccessFactors HXM Suite all versions

Reproducing the Issue

1. Navigate to an employee profile.

2. In Personal information portlet select the Edit button.

3. The birth name alt 1 and birth name alt 2 are not visible even if the fields are enabled in Manage Business Configuration under "personalInfo" element.

Cause

This happen because the fields are not enabled in the person type configured "personalInfo_employee".

Resolution

1 - Navigate to 'Manage Business Configuration';

2 - Select the arrow on the left side of the 'personalInfo' topic;

3 - Select 'personalInfo_employee';

4 - Enable the fields birth-name-alt1 and birth-name-alt2 and save;

5 - Go to the employee profile and you will see that the fields will be there.

See Also

Person Type in BCUI | SAP Help Portal

2743842 - Birth Name Alternate Fields are not Visible - SAP for Me

Keywords

Person Type, Alternate name, BCUI, Birth name alt 1, personal information, previous name, language. , KBA , LOD-SF-EC-PER , Person Data (All Person Data Types) , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions