SAP Knowledge Base Article - Public

3414545 - What to do when PartNumber field is not found in KO context?

Symptom

On searching the product within the catalog, you can see that in the KO context the 'PartNumber' field is undefined for the same product.

Environment

SAP SALES CLOUD CPQ

Cause

This is expected behaviour.

Resolution

  • If the parameter Allow adding incomplete items in the Usertype page is disabled or the product configuration is incomplete, the PartNumber will be returned as an undefined value in the KO context.
  • That is an old behaviour.

Keywords

KO Context, Field, Blank, PartNumber, catalog, incomplete configuration , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Problem

Product

SAP CPQ all versions