Symptom
The 'setup primary' key option is disabled for the BYOK Configuration in SAC.
Environment
SAP Analytics Cloud Version: 2023.21.13
Reproducing the Issue
- Login to SAC.
- Go into System> Administration> External Systems.
- BYOK Configuration.
- Setup Primary key is disabled.
Cause
The Security Administrator role was not assigned for the user.
Resolution
Need to provide Security Administrator role to the user as it has the BYOK Administration enabled in SAP Analytics Cloud.
Check this document for reference: https://help.sap.com/docs/SAP_ANALYTICS_CLOUD/00f68c2e08b941f081002fd3691d86a7/3676675895c9441897c5e82a112703a4.html
See Also
- Connect SAP Analytics Cloud to SAP Data Custodian | SAP Help Portal
- https://answers.sap.com/questions/13806677/details-on-byok-enablement-in-sac-tenant.html
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an case for SAP Analytics Cloud?
- 2511489 - Troubleshooting performance issues in SAP Analytics Cloud
- Search for SAP Analytics Cloud content using Google or Bing:
- https://www.google.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud Connection Guide
- Getting Started with SAP Analytics Cloud Expert Community page
- SAP Analytics Cloud Get More Help and SAP Support
- Need More Help? Contact Support or visit the solution finder today!
Keywords
BYOK Configuration, Primary key , KBA , LOD-ANA-ADM , SAC Administration , Problem
Product
SAP Analytics Cloud 1.0