SAP Knowledge Base Article - Public

3415220 - 500 Error When Trying to Send Order Confirmation to Account in Sales Order

Symptom

You receive a system exception (dump) when clicking the 'Send Order Confirmation to Account' button in a Sales Order.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Sales Orders work center.
  2. Open the Sales Orders view.
  3. Find Sales Order ABC (Where ABC represents the Sales Order ID).
  4. Open the Sales Order.
  5. Click on the View All button.
  6. Click on the Submit button and choose the 'Send Order Confirmation to Account' option.

An Error 500 occurs and the confirmation is not sent.

Cause

If you are sending order confirmations via business-to-business communication (B2B), one of the possible reasons for this is because the system requires the scoping question "Do you want to receive sales orders electronically from your customers using Electronic Data Exchange?" to be enabled in order for this process to work.

Resolution

In order to enable the scoping question, follow these steps:

  1. Go to the Business Configuration work center.
  2. Open the Implementation Projects view.
  3. Highlight the relevant Implementation Project.
  4. Click on the Edit Project Scope button. 
  5. Navigate to Step 4 (Questions).
  6. Expand "Sales" and then "Selling Products and Services".
  7. Select Option "Communication for Selling Products and Services".
  8. Enable Question "Do you want to receive sales orders electronically from your customers using Electronic Data Exchange?"
  9. Save the Implementation Project.

Keywords

Dump, Error, 500, Exception, Impossible, Unable, Send Order Confirmation to Account, B2B, Internal EDX, Sales Order. , KBA , AP-SLO-SO , Sales Order , How To

Product

SAP Business ByDesign all versions