Symptom
You have created a Sales Order from a Purchase Order during an intercompany process scenario, and you are not able to release the document due to the error Country/Region in address of Service Recipient party missing.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Sales Orders work center.
- Select the Sales Orders view.
- Search for ID ABC (ABC represents the ID of the Sales Order).
- Click Edit.
The following error shows: Country/Region in address of Service Recipient party missing
Cause
The reason the system is showing the error message Country/Region in address of Service Recipient party missing, is because the Service Recipient has not being maintained as Ship-To under the account data.
Resolution
This is the system behavior.
As the system does not perform dynamic updates from the account data to already created documents, please proceed with the following:
- Go to the Account Management work center.
- Select the Accounts view.
- Search for Account XYZ (XYZ represents the ID of the Account).
- Click Edit.
- Navigate to the Contacts tab.
- Select the Relationships subtab.
- Click the Add Row button.
- Select Has Ship-To Party and maintain the expected Service Recipient as the Business Partner.
Once this is completed, please cancel the respective Sales Order and Purchase Order, and recreate new documents with the updated data.
Now the system is able to retrieve the expected address details.
See Also
2738172 - Error: "City in address of Account, Ship-To, and Bill-To party missing"
2633213 - Intercompany Sales Order Cannot Be Released Due To Errors
2821916 - Error 'City in address of Bill-To party missing' in Intercompany Sales Order
2935240 - Error: Item XX: City in address of Ship-To party missing occurs for Intercompany Sales Order
Keywords
Error, Sales Order, Purchase Order, Intercompany, Country/Region in address of Service Recipient party missing, Service Recipient , KBA , AP-SLO-SO , Sales Order , How To