SAP Knowledge Base Article - Public

3415733 - KUT Fields Added To Products Facet Within An Opportunity Cannot Be Made Editable. 

Symptom

KUT fields added to Products facet within an opportunity cannot be made editable. 

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Sales.
  2. Open any Opportunity and then open Products Tab.
  3. In product tab, you notice that KUT fields are read-only, even trough you did not set these to be.

Cause

There are no CTs controlling this propriety, nevertheless the fields are still read-only. The scenario is presenting itself like this because the fields were created on "Material - General Information" business context. By design this context can only be changed at Material context, so the field could be added there, but just as read-only.

In Products list, we have two business contexts options while creating extension fields:

1. Material - General Information

2. Opportunity - Item

Resolution

Customer can add extension fields on this list from any of the above contexts. The extensibility anchor has been defined with readOnly = "true". Expectation is that customer can add extension fields from BO Material, node Common to the list, but they should be read Only. These extension fields should not be changeable in the Opportunity TI.

Keywords

KUT; fields; Products; opportunity; read-only; editable.  , KBA , AP-RC-UIF-FLX , Page Layout & Key User Configuration , LOD-LE-PRD-PRD , Product + Product Category Hierarchy , How To

Product

SAP Cloud for Customer core applications 2311