SAP Knowledge Base Article - Public

3415784 - Field Filters selection is not working when used in a regular filter - Integration Center

Symptom

You are building an integration in Integration Center and you add a new filter to it through the "Filter and Sort" tab.

In this new filter, you select a one-to-many navigation and use a Field Filter to select a specific value, but the filter ends up not working.

This issue will also happen if you use a pre-defined filter which uses Field Filter, for example the emailNav to Email Information-Business or to other email types in PerPerson:

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors HXM Suite
    • Integration Center

Reproducing the Issue

  1. When editing the integration, go to "Filter and Sort" tab and add a new filter
  2. Select a field and add a Field Filter:



  3. This Field Filter ends up not working, values other than the one you provided are still included in the integration output.

Cause

Field Filter doesn't work in regular filters from "Filter and Sort" tab.

Resolution

Field Filters will only work when used in these scenarios (refer to the Help Portal page Resolutions to Common Problems in Integration Center | SAP Help Portal):

  • Fields in "Configure Fields" tab (Configure Fields tab > Add Field)
  • Calculated Fields (Configure Fields tab > Add Calculated Field)
  • Calculated Filters (Filter and Sort tab > Advanced Filters section > Calculated Filter)

If you need to use the Field Filters in regular filters, note that it will not work. So please consider using Calculated Filters instead.

Keywords

filter, not working, field filter, field filters, navigation, , KBA , LOD-SF-INT-INC-FWK , Integration Center UI Framework , Problem

Product

SAP SuccessFactors HCM suite all versions