Symptom
You want to rename a field in enterprise search but doesn't find it via language adaptation tool.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Search for a record under enterprise search.
- Notice that there is a field you wish to rename.
- Look for it under Language Adaptation tool and notice that it is not there to be relabeled.
Cause
For Enterprise Search, only 'Enterprise search Categories' (when you search, you can filter the category in drop down list) can be translated using Language Adaptation.
Reference: KBA: 2899871 - Language Adaptation for Enterprise Search Categories
However, for the other texts in enterprise search, they are not covered by language translation and cannot be translated.
From the development perspective, there is no adaptation supported for Enterprise Search Screen. The field "Owner" cannot be translated via tool per system design. https://influence.sap.com/sap/ino/#/campaign/1868
Resolution
This is the expected system behavior.
You can access our Influence Portal and suggest an improvement in this scenario if you believe it could best serve your business purposes: https://influence.sap.com/sap/ino/#/campaign/1868
See Also
KBA: 2899871 - Language Adaptation for Enterprise Search
Keywords
Rename; translate; relabel; name; label; field; enterprise search; language adaptation; tool. , KBA , LOD-CRM-SBS-ES , Search , BC-DWB-REP-EXT , Extensibility , How To