SAP Knowledge Base Article - Public

3416205 - Reason for Rejection field is Grayed Out in a Sales Order Linked to a Project

Symptom

You notice that after maintaining a Reason for Rejection in a Sales Order linked to a Project document that was Released, it is no longer possible to revert the changes from the UI as the Reason for Rejection field becomes grayed out.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Sales Order Work Center.
  2. Go to the Sales Order View.
  3. Filter for All Orders.
  4. In the search field, search for the Sales Order ABC (where ABC represents the Sales Order ID).
  5. Open, Select View All.
  6. Navigate to the General tab.
  7. In the Reason for Rejection field, select any of the available values.
  8. Select Save button.

The Reason for Rejection field becomes grayed out in the Sales Order document.

Cause

Once a Sales Order linked to a released Project is rejected via Reason for Rejection in the General tab, no further changes can be performed as this is a permanent action for the document.

The Reason for Rejection field becomes grayed out and cannot be reversed in the UI.

Note: According to our development team this action cannot be reversed in the backend as well.

Resolution

This is expected system behavior.

In case the Reason for Rejection was incorrectly maintained for the Sales Order document, it will be required to recreate the Sales Process for the Sales Order and Project document manually in the system as the actions performed cannot be reversed.

Keywords

project, reject, reason for rejection, sales order, field, grayed out , KBA , AP-SLO-SO , Sales Order , SRD-PRO-PMN , Project Management , How To

Product

SAP Business ByDesign all versions