Symptom
The author of Social Media Message OWL is different from data in the ODATA API console.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Log in to the system.
- Go to Administrator - Social Media Messages.
- In the OWL view, you can see some authors' names are 'A', which is different from the one in ODATA API.
- Check for ODATA API console, author name is showing as 'B'.
Cause
- For Inbound messages, the provided name (channel name) is shown as author. This is designed in a way because in case of inbound response, the activity is created as an integration to C4C via payload where as the actual communication may have been done by any other agent.
- In this case, in Author Information name field is filled with Author as 'B'. But the channel of the message is 'A'. Hence, author of the message would be the provided name (channel name), which is A.
Resolution
This is the standard behavior of the system.
Keywords
KBA , LOD-CRM-SC-SM , Social Media , Problem
Product
SAP Cloud for Customer core applications all versions