SAP Knowledge Base Article - Public

3417187 - Section 2 prompting a new version I-9 form even when the completed Section 1 was already on the latest I-9 form - Onboarding

Symptom

When the Restart I-9 option is selected and the candidate redoes the Section 1, the same error still appears on Section 2. Thus, candidate and hiring manager are stuck in a never ending cycle.

"The Form is updated to the latest version, and the previous I-9 Section 1 is no longer valid. You must restart the I-9 process to generate a new Form I-9 that uses latest version. Please restart the I-9 process for this new hire, so they can sign the updated Section 1."

Environment

SAP SuccessFactors Onboarding

Cause

Cause 1: 

There are two ongoing I-9 compliance processes for the users in BPE: Monitor Processes. The older one, created some time ago, was never completed end-to-end. The existence of multiple AssignedComplianceForm objects, which are automatically extracted, returning the id for the older form. We need to avoid such a scenario by ensuring only one I-9 compliance process is active at a time. Older processes need to be cancelled. 

Cause 2:

  • For certain situations, even when Section 1 was completed using the new 2023 Form I-9, and Section 2 is triggered, the Section 2 task prompts the user to initiate Section 1 again using the new form. This is happening for rehires, and employees that had the 'I-9 Section 1 Awaiting SSN' task.
  • The candidate doesn't provide the SSN in Section 1/ SSN was incorrect.

Resolution

Solution 1

  1. Find out if there are multiple I-9 compliance processes open for the same user. For that follow these steps:
    1. Go to BPE: Monitor Processes
    2. Click in the Filter Icon > Go to Variables > inform userId=pasteTheCandidateUserIdHere > Apply the filter
    3. Check if there more than one "Unfinished" process with Process Definition ID as "Onboarding2I9Workflow" . (Ensure that you checked all the BPE pages available to the filter.)
    4. If there are multiple, go to manage data -> AssignedComplianceForm
    5. Search with the userid of the candidate
    6. Check if there is any form "open" or "not started" with I9_SECTION2_2020_V1 (please ensure that the status is just "open" or "not started" and the form is "2020")
    7. We need to delete this object.
    8. Once done, you can head to the onboarding dashboard for the new hire and attempt completing I-9 Section 2. (Please do NOT attempt this via CARD as it may refer to an older compliance, it,s needed to complete in Dashboard task)
    9. No RESTART pop-up should appear in this case.

Solution 2

What would be the best practice: users should decline signature step which will reinitiate I-9 Section 1 step properly. Then they can provide SSN in Section 1 and proceed forward with I9 Section 1 signature followed by I9 Section 2.

However, in order to get it resolved for affected candidates, please follow below steps:

  1. In Manage Data > Compliance Process Task > find I-9 task which still has Task status as in progress (search for user Id/ Person Id) > Manually set task status to "completed".
  2. In BPE: Manage User Tasks > Click on Filter icon and provide the affected Process Instance ID.
    In order to get it: 
    1. In 'Global Search' search for 'BPE:Monitor Processes'
    2. Click on the Filter icon > Go to 'Variable' and inform 'userId=paste the user ID' > Apply the filter
    3. In the 'Process Definition ID' column find the line with 'Onboarding2I9Workflow' text and that is 'unfinished' in status
    4. Copy the ID available in the first column
  3. Go to BPE: Manage User tasks > Filter > Process Instance ID > paste it here and select it > Click "Complete Task'" Button.

After doing this, I9 Section 1 Signature step for the affected user can be completed.

IMPORTANT! If SSN correction was not done, however the message still appears to users, raise a case with Onboarding Support team: LOD-SF-OBX-FRM.

See Also

3338117 - Error is being received and unable to complete US I-9 Section 2 for a candidate - Onboarding

Keywords

Onboarding, obx, I-9, I9, form, section1, section 2, complete, SSN, number, trigger, correction, again, SSN, "the form I-9 is updated to the latest version, and the previous I-9 section 1 is no longer valid", "you must restart I-9 process to generate a new form I-9 that uses latest version", "please restart the I-9 process for this new hire"  , KBA , LOD-SF-OBX-FRM , Compliance 2.0 Country Forms (except i9&EV) , Problem

Product

SAP SuccessFactors Onboarding all versions