Symptom
Internal candidate cannot apply for jobs due to missing Last Name or First Name.
Environment
SAP SuccessFactors Recruiting Management
Cause
The information is blank in the Candidate Profile in Recruiting.
The issue happens if the field is mapped between Employee Profile and Candidate Profile via sm-mapping.
Resolution
Pre-requisite:
- The employee's name is filled in the Employee Profile.
- The field mapping for the name has been correctly defined in the sm-mapping section in the Candidate Profile template. KBA 2644262 - Modifying sm-mapping fields via Manage Templates Feature
To synchronize the employee's name from the employee profile to the internal candidate profile, you can save either the candidate profile or the employee profile.
To trigger a synchronization from the candidate profile, follow these steps:
- Navigate to Careers > My Candidate Profile.
- Make any changes to a field and then revert it back. This action will activate the save button.
- Click on the save button.
Keywords
RCM, candidate, profile, name, required, career portal, missing , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , LOD-SF-RCM , Recruiting Management , LOD-SF-RCM-APP , Applicants and Job Applications , Problem