Symptom
When creating a new Talent Pool or editing an existing one, the option to search for a country returns with "No data"
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Recruiting
Reproducing the Issue
- Log into the Instance
- Go to Recruiting
- Go to Candidates
- Click on Talent Pools
- Create a new Talent Pool or edit an existing one
- Under Additional Details > Country, click on the filter icon:
- Type the name of a country and click on Search
- "No data" is displayed:
Cause
Customer is using a custom country pool, instead of the standard country pool, and its “externalName” property is not set to “Translatable” type.
As this filter always retrieves values from “externalName_xx_XX” (example: externalName_en_US), it only works with the assumption that:
- The property name is always externalName or name
- The property is always translatable type field
Resolution
- Create a new customized object definition similar to the already existing custom country pool and make sure its “externalName” property is set to “Translatable” type.
- Create data for this object as per already existing custom country pool.
- Configure “CRMPoolExtension” object definition with this new object definition, and remove the original association to the existing custom country pool:
> Go to Configure Object Definition, search for Object Definition: Candidate Relationship Management Pool Extension (CRMPoolExtension). It is configured with associations similar to below screenshot
- Refresh OData Metadata -> Click “Refresh” in “OData API Metadata Refresh And Export“ and wait for refresh to complete.
- Try to search for the country in the Talent Pool again and see that the list of countries appears as expected.
Keywords
Talent, Pool, Country, Filter, Details, No data , KBA , LOD-SF-RCM-CRM , Candidate Relationship Management , Problem