Symptom
An inbound (insert) Integration Center job is failing with the error below:
"<entity name>: UPSERT failed for the row with key: <entity name>/<entity field>=xxxxx,<entity name>/<entity field>=xxxxx. Reason: Cannot be merged as the conflict value found for properties: <entity field>"
Environment
SAP SuccessFactors HXM Suite
Cause
In the preview payload (under Configure Fields > Field Mapping View) we can see there are multiple upserts for the same record. Note a record is defined and identified by its business keys.
OBS.: The entities business keys can be found in OData API Data Dictionary.
For example:
{
"businessKey1": "123",
"businessKey2": "xxx",
"field1": "abc",
...
}
{
"businessKey1": "123",
"businessKey2": "xxx",
"field1": "xyz",
...
}
In this example, different values for "field1" are trying to be upserted in the same record in the same payload which led to Integration Center cannot decide which one to be used, so backend throws out the error instead of overriding it with some implicit logic.
Resolution
Make the records being upserted unique (with unique business keys).
To achieve that you'll need to review the mapping of the business keys (refer to Field Mapping View for Inbound Integrations).
If the related entity is custom, review its business keys may be necessary as well (refer to MDF guide).
Keywords
error, issue, upsert, failed, cannot be merged, conflict value found for properties, Integration Center, ic, sf, inbound, insert, custom object, business key , KBA , LOD-SF-INT-INC , Integration Center , Problem