Symptom
In a contract account, the deferral date is mandatory. If you do not enter a date once, the system shows an error message as expected. However once a date is set afterwards and you try to change it again without date, the save goes through and the date is removed.
Environment
Cloud for Customer
Reproducing the Issue
- Open the Contract Account.
- Navigate to the tab Open Items.
- Click on the Deferral button and choose the line items from the pop up. Click Save.
- The system shows an error message with regards to the missing date of deferral.
- Enter the date and click Save.
- A deferral message is shown as success on the screen.
- Click again on the Deferral button and select the line items from the pop up. Click Save without entering a date.
This time system does not asks for the date, rather the deferral gets removed.
Cause
If the deferral date for a selected open item already exists, and you execute the deferral action without entering a new date, the application won't return an error. This is because the record already has a deferral date, and during the action execution, a new deferral date is not entered, leading to it passing an empty value and overwriting the existing deferral date.
Resolution
This is required for those cases, where for example the call center wants to remove the deferral date of an open item. Otherwise there wouldn't be any option to overwrite it with an empty value.
So we are checking both the selected record and the deferral date input. If both are empty, then the service will return an error.
Keywords
deferral, date, missing error message, overwritten, contract account, utilities , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To