SAP Knowledge Base Article - Public

3419190 - "No data available or you do not have the necessary permission" error after an instance refresh

Symptom

After an instance refresh, when trying to create a new record for an MDF object (under SuccessFactors > Manage Data), the error below is being thrown:

"No data available or you do not have the necessary permission"

In the instance that was copied, all is working fine.

OBS.: If your scenario wasn't after an instance refresh, refer to the KBA 2515900.

Environment

SAP SuccessFactors HCM Suite

Cause

Permissions not sync for the logged user.

Resolution

Remove and grant again the standard permissions related to this MDF object for the logged user.

Additionally, under Configure Object Definition > Search for the object > Security section (end of page), check if the object is Secured. If so, remove and grant again the specific permission showing up there as well.

See Also

KBA 2515900 - No Permission Error when creating data for custom MDF object

Keywords

instance, refresh, error, issue, No data available, do not have the necessary permission, manage data, create, record, mdf, object, entity , KBA , LOD-SF-PLT-IRT , Instance Refresh Tool , LOD-SF-MDF , Metadata Framework , Problem

Product

SAP SuccessFactors HCM Suite all versions