SAP Knowledge Base Article - Public

3419215 - Format (XX) of selected print queue doesn't match format of document (YY) - SAP S/4HANA Cloud

Symptom

Following error message is encountered during generation of PRINT channel output item : "Format (XX) of selected print queue doesn't match format of document (YY)"

Environment

SAP S/4HANA Cloud

Reproducing the Issue

The following is an example for billing document:

  1. Open app Change Billing Documents
  2. Navigate to Output Items screen
  3. Add a new duplicate output item 
  4. Error in error log is displayed similar to 'Format (XX) of selected print queue doesn't match format of document (YY)'

Cause

This error message is expected only when an existing output item is added again (duplicate) using a different print queue (with another format) or when the output could not be completed and upon retry the print queue format has changed in the meantime.

For the original output item, the document is always rendered in the format of the selected print queue, so this error should not occur in an ideal use case.

Resolution

  1. Make sure that the format of the document to be rendered is in the same format of the print queue.
  2. Instead of using 'Duplicate' function, use 'Add Output' function to generate a new original output item.

See Also

3262821 - Adding a new Output Item is not possible due to error: "You can only issue one Output Item for an Original Ivoice" - S/4HANA Cloud

Setting Up Output Management

Keywords

Print Queue, PDF, PCL, PDL, print, format, 1LQ, Public Cloud, Output, duplicate, warning, error message , KBA , CA-GTF-OC , SAP S/4HANA output management , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions