SAP Knowledge Base Article - Public

3419799 - Party Role field not available in Code-list restrictions for Service Request BO (Tickets)

Symptom

When trying to add code list restrictions with respect Service Request (Tickets) BO, the "party role" field is not available in the code to restrict dropdown

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP Cloud for Customer

Reproducing the Issue

1. Login to C4C.

2. Go to Administrator General Settings  Code List Restrictions.

3. Click on "+" (Create) to open the New Code List Restriction screen.

4. In the new screen, select the following:

    1. Business Object for which you want to restrict certain code types. (Service Request (Tickets) in this case). 
    2. Code to Restrict (Party Role in this case).

5. Notice that the party role field does not appear in the drop down.

Cause

Party Role field is not exposed/available for the Business Object Service Request, which is used by Tickets. Hence Party Role is not available for Code List Restrictions in this case.

Resolution

Kindly Note - Party Role field is available in Customer, Opportunities and Leads. However, these are all different Business Objects. 

Currently Party Role field is not available for the Business Object Service Request, which is used by Tickets. 

So in this case this behavior is not supported in SAP Cloud for Customer and the system behaves as expected.

Keywords

Party Role, Service request BO, Tickets , KBA , AP-RC-UIF , C4C UI Framework , Problem

Product

SAP Cloud for Customer core applications all versions