Symptom
There is a business requirement to use custom reversal reason for payment rejection.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open the Manage Incoming Payment Files app.
- Choose Import.
- In the File Type field, choose Payment Rejection, and in the Format field, select the electronic payment file you want to use.
- Choose the plus sign to upload the rejection file you received from the bank.
- After you have selected the file, choose Process.
Cause
The reversal reason for payment rejection is considered from the posting rule REJ9. The posting rule REJ9 is configured as below:
Posting Rule | REJ9 |
Posting Area | 2 |
Document Type | ZP |
Posting Type | 9 |
Reversal Reason | 01 |
Resolution
As posting rules is a pre-delivered configuration from SAP, it is not possible to make any changes to the posting rule. A WCR request to create a new posting rule with a custom reversal reason has to be raised after consulting with the Customer Sucess Partner; however, the creation of a new posting rule is considered to be a non-standard expert configuration. This is a customer-specific request, so it needs to be followed by the review process for non-standard configuration request.
See Also
Reversal, payment file, PAIN.002, payment order, Manage Incoming Payment Files, Monitor Payments, 101039, RJCT, payment rejection file
Keywords
KBA , FI-AP-AP-B1 , Payment transfer (w/o DE, US) , FI-BL-PT-BA-2CL , bank statement (Public Cloud) , FIN-FSCM-BNK-2CL , Direct Bank Communication (Public Cloud) , Problem