SAP Knowledge Base Article - Public

3420646 - "No customer master is linked to business partner" message raised in Service Order.

Symptom

When assigning a Partner function in the Manage Service Order app, the error "No customer master linked to Business Partner" is raised.

Environment

SAP S/4HANA Cloud

Reproducing the Issue

  1. Open the Manage Service Order App.
  2. Select relevant Service Order record. 
  3. Click Edit. 
  4. Attempt to add a new value under the Partner section.
  5. Error is raised. 

Cause

The Business Partner selected to be added as a new value in the Partner Section is not extended to the Customer role. 

Resolution

  1. Open the Maintain Business Partner App. 
  2. Select the relevant record. 
  3. Put the Business Partner into edit mode. 
  4. Select the Role dropdown. 
  5. Set the value as FCLU01.
  6. Enter the relevant Sales and Distribution data.
  7. Click Save. 

Keywords

BP, Business Partner, No customer master linked to Business Partner, service order, s/4hana cloud, s/4hana, service, sales and distribution, role, FLCU01 , KBA , CRM-S4-SRV-SVO-2CL , S4CRM: Service Order (Public Cloud) , LO-MD-BP , Business Partners , Problem

Product

SAP S/4HANA Cloud 2308