Symptom
When assigning a Partner function in the Manage Service Order app, the error "No customer master linked to Business Partner" is raised.
Environment
SAP S/4HANA Cloud
Reproducing the Issue
- Open the Manage Service Order App.
- Select relevant Service Order record.
- Click Edit.
- Attempt to add a new value under the Partner section.
- Error is raised.
Cause
The Business Partner selected to be added as a new value in the Partner Section is not extended to the Customer role.
Resolution
- Open the Maintain Business Partner App.
- Select the relevant record.
- Put the Business Partner into edit mode.
- Select the Role dropdown.
- Set the value as FCLU01.
- Enter the relevant Sales and Distribution data.
- Click Save.
Keywords
BP, Business Partner, No customer master linked to Business Partner, service order, s/4hana cloud, s/4hana, service, sales and distribution, role, FLCU01 , KBA , CRM-S4-SRV-SVO-2CL , S4CRM: Service Order (Public Cloud) , LO-MD-BP , Business Partners , Problem
Product
SAP S/4HANA Cloud 2308