Symptom
When you use an E-Mail template in the ticket Interactions facet, you see an empty line is inserted at the beginning of texts.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Service work center
- Go to the Tickets view
- Open the Ticket 123 (Where 123 refers to the Ticket ID)
- Go to the Interactions tab
- Click New
- Select a template
- Click Select
Result: Texts in the template are inserted in the editor with an empty line at the beginning.
Cause
This is a standard behaviour of the TinyMCE editor. Please refer to the different scenarios below.
- When you use a Text-Based template, this always happens
- When you use a Document-Based template, this happens but an empty line will be removed by clicking on a Text area
- When you use a Document-Based template which has only a single line of text, this does not happen
- When you disable the TinyMCE editor, this does not happen
Resolution
To remove an empty line manually when using a template, or to disable the TinyMCE Editor.
Keywords
empty, line, space, template, e-mail, email, Text-Based, Document-Based , KBA , LOD-CRM-SRP , Service Request Processing , Problem
Product
SAP Cloud for Customer core applications 2311