SAP Knowledge Base Article - Public

3420778 - Empty Line When Using E-mail Template in Ticket Interactions

Symptom

When you use an E-Mail template in the ticket Interactions facet, you see an empty line is inserted at the beginning of texts.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Service work center
  2. Go to the Tickets view
  3. Open the Ticket 123 (Where 123 refers to the Ticket ID)
  4. Go to the Interactions tab
  5. Click New
  6. Select a template
  7. Click Select

Result: Texts in the template are inserted in the editor with an empty line at the beginning.

Cause

This is a standard behaviour of the TinyMCE editor. Please refer to the different scenarios below.

  • When you use a Text-Based template, this always happens
  • When you use a Document-Based template, this happens but an empty line will be removed by clicking on a Text area
  • When you use a Document-Based template which has only a single line of text, this does not happen 
  • When you disable the TinyMCE editor, this does not happen

Resolution

To remove an empty line manually when using a template, or to disable the TinyMCE Editor.

Keywords

empty, line, space, template, e-mail, email, Text-Based, Document-Based , KBA , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer core applications 2311