SAP Knowledge Base Article - Public

3421017 - Job Application Custom Tokens not resolving in e-mails for Forwarded candidates - Recruiting Management

Symptom

The job application custom tokens, for example [JOB_APPLICATION_CUSTOM1], are not resolving in e-mail notifications triggered by default status Forwarded.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. You configure a job application custom token
  2. You set up an e-mail to be triggered at the moment the candidate is placed in the Forwarded status
  3. You forward a candidate to requisition to Forwarded status
  4. Candidate receives the e-mail but in the body of notification it's displaying [JOB_APPLICATION_CUSTOM1], the token is not getting resolved

Cause

Candidates in Forwarded status have not applied yet.

Resolution

It has been confirmed by Engineering team this is expected behavior.

When forwarding a candidate to Forwarded status from any job requisition, the application tokens in triggered e-mail will not resolve because the application is not created yet in a forwarded status. Application tokens will resolve only if an application is created for that candidate and a value is filled for that token correspondent field in that job application.

Keywords

JOB_APPLICATION_CUSTOM, status, trigger, notification , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem

Product

SAP SuccessFactors Recruiting all versions