SAP Knowledge Base Article - Public

3421125 - Pricing facet is not visible in Contracts

Symptom

When trying to make the 'Pricing' facet visible in a Service Contract, even though it is enabled it via Adaptation, it is still not showing up

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Contracts Work Center
  2. Open a Service Contract
  3. Start Adaptation
  4. Try to make 'Pricing' visible

Cause

The 'External Data' checkbox is disabled in "Service Contracts" Activity from Business Configurations.

In order to have Pricing in contracts, the External Pricing must be in place

Resolution

  1. Open "Business Configuration" Work Center
  2. Click on "Overview"
  3. Search for "Service Contract" and open it
  4. Click on "Maintain Document Types"
  5. Add Row
  6. The "External Data" is disabled
  7. In order to correct it, you need to Enable the "External Data" flag

Keywords

Service Contracts, Pricing, External Pricing, External Data , KBA , LOD-LE-COP-SRV , Service Contract , How To

Product

SAP Cloud for Customer core applications 2311