SAP Knowledge Base Article - Public

3421277 - Sales Order Line Item Delivery Status and Invoice Status Not Changed to Completed After Reason For Rejection is Maintained

Symptom

Sales Order line item delivery status and invoice status not changed to completed even though the reason for rejection is maintained for the line item. 

Environment

SAP Business ByDesign 

Reproducing the Issue

  1. Go to Sales Orders work center.
  2. Go to Sales Orders Processing view.
  3. Edit Sales Order XYZ (XYZ represent Sales order ID) and click on View all.
  4. Navigate to Items tab.
  5. Select line item and the under General sub tab Reason for Rejection is maintained.

Line item delivery status and invoice status not changed to completed

Cause

Cancellation of sales order item does not mean that the delivery and invoice is finished and hence the delivery and invoice status is not affected by cancellation.

Resolution

This is the intended system behavior.

Keywords

Not Started status to Completed;  , KBA , AP-SLO-SO , Sales Order , Problem

Product

SAP Business ByDesign all versions