Symptom
Some of your Business Partner Merges runs end up in status Merge Completed - Realignment Failed.
Automatic Merge (010101) | ObjectID (ABC1234...)
Error occurred for Contract 123456
Locking object not possible; object locked by "USER"
Environment
SAP Cloud for Customer
Reproducing the Issue
1. Go to Customer Merge work center.
2. Search for the status Merge Completed - Realignment Failed one.
3. Open and go to Result Log facet.
4. On results tab, click on the "Application Log ID" for the one with Error.
5. On the new page under "Summarizing Messages", drill down the line with the red Status.
6. Drill down all sub lines in red statuses.
7. You will see: Locking object not possible; object locked by
Cause
Possible root causes:
1) Some other process locks those contracts. Then the update from Merge will not be possible.
2) Same contracts are part of different merge cases and these are created + executed in parallel. Based on the name of the merge cases, there seems to be a customer specific process to create merge cases.
Resolution
Usually for such scenarios, the error showing up is a foreign lock situation when trying to re-assign the party in the Customer Contract.
Wait for some time and try to re-start the merge and check if the issue persists.
Keywords
Merge; Failed; Completed; Lock; Locking; Realignment; Object , KBA , LOD-LE-BP-MRG , Business Partner Merge , Problem