Symptom
When trying to import mappings or add mappings via Manage Data, receive an error:
Talent Intelligence Hub ID is null, so the user is not allowed to add any mapping
Environment
- SAP SuccessFactors Talent Intelligence Hub
- SAP SuccessFactors Job Profile Builder
- SAP SuccessFactors Job Description Manager
Reproducing the Issue
- Log in to SuccessFactors
- Navigate to Admin Center > Manage Data
- In the first Search, select Role
- In the second Search, select a role
- Select Take Action > Make Correction
- In the Mapped Competencies section, add a competency > Save
- Receive error
OR
- Log in to SuccessFactors
- Navigate to Admin Center > Import and Export Data
- For Select the action to perform, select Import Data
- Select any JDM or JPB mapping entity
- Select a file to import > Import
- Receive error
Cause
- The wsmID field is blank in Manage Data
- Attributes are missing from Talent Intelligence Hub
Resolution
Engineering will need to process an instance refresh to resolve the issue:
- Take a backup of all competencies and behaviors
- Create a case with Product Support under component LOD-SF-TIH-MIG with the below required details:
- Data Center (URL of your login screen):
- Company Instance ID (where to apply changes):
- Confirmation you have taken a backup of all competencies and behaviors
- Approval
Keywords
success factors, tih, imports, importing, cannot map, can not, entities, mapped, map, mapping, attributes, competencies, roles, behaviors, WSM-24659 , KBA , LOD-SF-TIH-LIB , Attribute Library , LOD-SF-TIH-JPB-ADM , Admin Center, Settings, Permissions , LOD-SF-TIH-JDM , Job Description Manager , LOD-SF-MDF-IMP , Import and Export Issues , LOD-SF-MDF-MGD , Manage Data - Create, Update & Delete , Problem