Symptom
- SAC logon stuck in default IdP page, for example https://<tenant>.authentication.eu10.hana.ondemand.com/login
- SAC logon page cannot direct to custom IdP logon page
- SAC fail to redirect to custom IdP logon page
- Cannot logon to SAC tenant
Environment
- SAP Analytics Cloud 1.0 (SAC)
Reproducing the Issue
- Open SAC URL in browser. For example https://<>.eu10.sapanalytics.cloud/
- "Welcome to <tenant name>!" displayed while stay in https://<tenant>.authentication.eu10.hana.ondemand.com/login. Cannot redirect to custom IdP page.
Cause
Check the http trace while logon. Status Code: "302 Found" is displayed in Request URL: https://<>.authentication.eu10.hana.ondemand.com/oauth/authorize?response_type=code&client_id=xxxxxxxx%2Fsso%2Flogin%2Fcallback
There is some change done in IdP server / service. So the metadata file in IdP admin is outdated.
Resolution
Upload new metadata file in IdP admin tool to update the change in IdP server.
Follow
From Step 1 -4 and Step 6. (Optional) Upload new metadata for the current custom identity provider.
Keywords
KBA , LOD-ANA-ADM , SAC Administration , LOD-ANA-AUT , SAC Authentication / Login , Problem
Product
SAP Analytics Cloud 1.0