SAP Knowledge Base Article - Public

3422631 - Multiples messages received in CPI for 1 single C4C Webservice Call

Symptom

You made a single webservice call, which resulted in many messages arriving in CPI.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Service WC
  2. Go to Tickets View
  3. Search and open a Ticket ABC ( ABC stand for the Ticket ID)
  4. Make any changes to the Ticket to activate the Workflow XYZ. ( XYZ stand for the Workflow name)
  5. Check the CPI log.

Cause

Workflow Rule, XYZ, has Recipient Determination = Service Technician Team for Ticket.

Resolution

The reason why CPI is getting multiples messages is because of the Recipient Determination. Workflow Rule, XYZ, has Recipient Determination = Service Technician Team for Ticket. For ticket ABC. Therefore, the workflow rule will send message notification to all employees in the Service Technician Team for Ticket. 

Keywords

Service technician, Workflow , CPI, Ticket ,Webservice call , KBA , LOD-CRM-WKF , Workflow , Problem

Product

SAP Cloud for Customer core applications 2311