Symptom
You made a single webservice call, which resulted in many messages arriving in CPI.
Environment
Reproducing the Issue
- Go to Service WC
- Go to Tickets View
- Search and open a Ticket ABC ( ABC stand for the Ticket ID)
- Make any changes to the Ticket to activate the Workflow XYZ. ( XYZ stand for the Workflow name)
- Check the CPI log.
Cause
Workflow Rule, XYZ, has Recipient Determination = Service Technician Team for Ticket.
Resolution
The reason why CPI is getting multiples messages is because of the Recipient Determination. Workflow Rule, XYZ, has Recipient Determination = Service Technician Team for Ticket. For ticket ABC. Therefore, the workflow rule will send message notification to all employees in the Service Technician Team for Ticket.
Keywords
Service technician, Workflow , CPI, Ticket ,Webservice call , KBA , LOD-CRM-WKF , Workflow , Problem
Product
SAP Cloud for Customer core applications 2311