SAP Knowledge Base Article - Public

3422728 - Update Opportunity Workflow is not working

Symptom

The Update Opportunity functionality is not working properly. The workflow has triggered, however it is not updating the opportunity.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Sales Quote
  2. Go to Action 
  3. Set as Won
  4. Observe: this will trigger the Workflow XYZ ( XYZ stand for the Workflow name)
  5. BUT the Expected Value is not getting updated with the Quote total value as expected.

Cause

The reason why the Action 'Update Opportunity' did not execute is because this Action is not available for the Quote. You can also validate this under Actions button, Update Opportunity is unavailable.

Resolution

If the customer wants this to work, they must have the action available from the UI as well. Whatever that cannot be performed in the UI, the Workflow Rule cannot perform neither. To check this follow the steps below:

Assign Opportunities to Sales Quotes

  1. Open an existing sales quote or create a new one.
  2. In the Opportunity header section, add an opportunity ID or description.
    If an opportunity is already assigned, you can enter another opportunity ID or description.
  3. Save your entries.
    You can set an assigned opportunity as Primary Quote. This action creates the Update Opportunity field. Once you click Update Opportunity,
  4. Notice that the Expected Value of the assigned opportunity has modified once you save your entries.
  5. Click Refresh.
  6. Click the Document Flow tab to view the assigned opportunity.

See Also

https://help.sap.com/docs/SAP_CLOUD_FOR_CUSTOMER/24765b551a014b779b95c7b07d8e9079/20f19689a7044526973960f2b9cd2dd8.html?locale=en-US

Keywords

Update Opportunity, Workflow, Sales Quote, Opportunity, Expected value, Total Value , KBA , LOD-CRM-WKF , Workflow , Problem

Product

SAP Cloud for Customer core applications 2311