Symptom
You have noticed that when you are using the Customer Contract Volume report (CRMCCOIB_Q0001), the contracts with status of In Preparation are not displaying as expected.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Business Analytics work center.
- Select the Design Reports view.
- Search for CRMCCOIB_Q0001 or Customer Contract Volume.
- Click on the Name's hyperlink to open.
- Add any filter, such as Last 365 days.
- Click Apply.
The In Preparation contracts are not displayed.
Cause
The Customer Contract Volume (CRMCCOIB_Q0001) report will only show contracts with released status equal to Release.
The reason of this is because the Customer Contract Item (CRMCCOIB) data source has an ‘hard coded’ filter based upon the Release status of the contract and it's item.
Resolution
This is the system expected behavior.
If you would like to view the In Preparation contracts, please use the Customer Contract Volume Extended (CRMCCOIB01_Q0001) report.
See Also
2921349 - How Does Reporting Works in Business ByDesign
2724953 - In Preparation Sales Order Missing in the Report
1982397 - Contract not shown on the Customer Contract Volume report
Keywords
Contract, In Preparation, Customer Contract Volume, Report, Missing, Not Showing, Status, CRMCCOIB , KBA , AP-SLO-SO , Sales Order , How To