Symptom
“Recruiting Manual Candidate Creation Notification" does not get triggered to the candidate when the candidate is created from the candidate search within the job requisition rather a status triggered email configured for the forwarded status gets triggered.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Go to Recruiting email triggers.
- Confirm that “Recruiting Manual Candidate Creation” Notification is configured correctly.
3. Go to Edit Applicant status configuration and confirm that an email template is configured for forwarded status for external candidates (It’s the status triggered email configuration).
4. Now go to the Job Requisition and create candidate profile from the Job Requisition Page.
5. This newly created candidate has the application in the forwarded status in the requisition.
6. Notice that no email gets triggered from the email trigger “Recruiting Manual Candidate Creation Notification” to the candidate, rather the status triggered email is triggered for the forwarded status.
Note: If the status triggered email is removed from edit applicant status configuration, Recruiting manual candidate creation candidate gets triggered to the candidate.
Cause
Product Management and the engineering team has confirmed that it is an expected behavior.
Resolution
The current behaviour is not a regression rather an improvement made in code post changes made as part of b1511 release.
Therefore, no two emails will get triggered. If your business need is to have the “Recruiting Manual candidate creation” getting triggered to the candidate, you will need to disable the status triggered email for the forwarded status.
Keywords
email, manual, candidate, profile, creation, job, requisition, two, trigger , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , How To