SAP Knowledge Base Article - Public

3423345 - Sync from Outlook is not working. Users got RBAM: No authorization errors.

Symptom

End users cannot synchronize a Visit from Outlook to cloud for a customer; the sync status returns from the cloud with information. RBAM error message indicates no authorization.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Customer
  2. Open any
  3. Go to the Visit Tab
  4. Create New
  5. Observe: ERROR- "RBAM: No authorization for 'BuiltIn <default> WRITE' on instance 'XXXXXXXXXXXXXXXXXXX' of 'BONodeProxy <default> BUSINESS_ACTIVITY <default> ROOT' in context 'UIApplication <default> /BYD_COD/SalesOnDemand/Visit/VisitExecution/COD_Visit_QC.QC.uicomponent <default> <default> Operation <default> Start'"

Cause

  • This could be related to the User's Access to the Visit Object.
  • In the Quick Create screen of the new Visit, the Sales Organization is not defaulted.
  • The user is not assigned to any Sales Organization.

Resolution

  1. Check the user's Access Right to Visit and validate.
  2. Check the Business Configuration to see how the Organisation Unit is defaulted in the new Visit Quick Create.
  3. Check to see if the user's Sales organization is flagged as 'Sales' at the Organization level.

Keywords

Access Right, RBAM, Organizational Unit, Sales Organization, Flagged Sales, Visit , KBA , LOD-CRM-ACT-VST , Visit Planning , Problem

Product

SAP Cloud for Customer core applications 2311