Symptom
Enterprise search is not showing up for one or more users.
Environment
SAP Cloud for Customer
Reproducing the Issue
In the homepage in the right top corner of the screen the magnifying glass icon to search is missing.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Cause
In company settings for the business role of the affected user, enterprise search is disabled.
Resolution
Activate enterprise search in company settings following these steps:
- Go to profile in the top corner of the screen.
- Go to settings.
- Go to company settings.
- Select business role of the affected user.
- Find the "Disable Enterprise Search".
- Click on "no".
- Click on save.
Keywords
Enterprise Search, EnterpriseSearch, Global Search, magnifying glass icon, Search Bar, Invisible, Missing , KBA , AP-RC-UIF-XTS , UI Framework Cross Topics , How To