SAP Knowledge Base Article - Public

3423458 - Enterprise Search Bar Is Not Showing in the UI

Symptom

Enterprise search is not showing up for one or more users.

Environment

SAP Cloud for Customer

Reproducing the Issue

In the homepage in the right top corner of the screen the magnifying glass icon to search is missing.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental. 

Cause

In company settings for the business role of the affected user, enterprise search is disabled.

Resolution

Activate enterprise search in company settings following these steps:

  1. Go to profile in the top corner of the screen.
  2. Go to settings.
  3. Go to company settings.
  4. Select business role of the affected user.
  5. Find the "Disable Enterprise Search".
  6. Click on "no".
  7. Click on save.

Keywords

Enterprise Search, EnterpriseSearch, Global Search, magnifying glass icon, Search Bar, Invisible, Missing , KBA , AP-RC-UIF-XTS , UI Framework Cross Topics , How To

Product

SAP Cloud for Customer core applications 2311