Symptom
You have translated a text via Language Adaptation and have successfully transported it to another tenant. The target texts are correctly shown in the created system, however the translation is not reflected in the UI of target system.
Environment
SAP Cloud for Customer
Reproducing the Issue
In the source system:
- Go to Administrator > General Settings;
- Language Adaptation > Open the desired LA;
- You can see the Target texts are correctly shown;
- Then go to the desired BO, for example, Customers > Individual Customers;
- Open Individual Customer ID ABC;
- Go to the desired facet;
- The target texts are correctly shown.
In the target system where the transportation has been made:
- Go to the desired BO, for example, Customers > Individual Customers;
- Open Individual Customer ID ABCD;
- Go to the desired facet;
- The target texts are not reflected. Old text is still being shown.
Cause
The text/field in question has been translated twice or more in different Language Adaptations.
It is not recommended to adapt/translate the same text/field towards the same target language by multiple Language Adaptations. These will lead to inconsistency on system, as system will not be able to define which translation should be reflected in the UI.
Resolution
Delete one of the language adaptations so system can select and show the correct translation in the UI.
Keywords
TR, transport management , KBA , AP-RC-TXA , C4C Text Adaptation , Problem