SAP Knowledge Base Article - Public

3424695 - Error When Saving Contract: Pricing failed, no receiver system. Check communication arrangement

Symptom

When trying to make a change in a contract, an error appears:

Save failed
Pricing failed, no receiver system. Check communication arrangement
Saved replicated contract cannot be saved if pricing is not calculated.
Contract not transferred to ERP. Please request external pricing update.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the work center Contracts.
  2. Open the contract in question.
  3. Try to make a change - for example, try to change the owner and save.

The error message is displayed.

Cause

You have changed the changed the Service Contract configuration for the same processing type code from bidirectional to inbound only.

As a consequence, you now have both bidirectional and inbound only contacts under the same document type. The contracts which have been created before and after the change require different settings to work correctly, which is technically correct.

Resolution

We would strongly recommend to avoid such a scenario. A new processing type should be created when you would like to use a different integration scenario (e.g. only inbound integration with one processing type versus bi-directional integration with another processing type).

To check if these changes were made:

  1. Go to the work center Business Configuration, view Reports.
  2. Open the report Configuration Change History.
  3. Go to the Fine-Tuning Activities tab and search for the activity Service Contracts.
  4. Click Download Change Details.

Here you will see if the direction was changed.

Keywords

service contract, cannot edit, communication arrangement, pricing failed, no receiver system, direction, inbound, bi-directional , KBA , LOD-LE-COP , Contract Processing , How To

Product

SAP Cloud for Customer core applications 2311