Symptom
When trying to make changes to a contract, for example changing the owner or similar, an error appears:
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the work center Contracts.
- Open the contract.
- Make the required change and click Save.
The following error appears:
Cause
One possible cause for this error is that you have changed the changed the configuration for the respective processing type code from bidirectional to inbound only.
As a consequence, you now have both bidirectional and inbound only contracts under the same document type. The contracts which have been created before and after the change require different settings to work correctly, which is technically correct.
Resolution
Ideally, a new processing type should be created when you would like to use a different integration scenario (e.g. only inbound integration with one processing type versus bi-directional integration with another processing type).
If you'd rather not change this, a potential workaround you could be to replicate the required updates from the external system to avoid errors. To avoid confusion through error messages however, we would suggest to adjust document types.
See Also
To confirm that changes were made, you can check here:
- Work center Business Configuration, view Reports.
- Click Configuration Change History.
- Go to the tab Fine-Tuning Settings.
- Look for the activity Service Contracts. You may need to adjust the time frame depending on when the changes were made.
- Click Download Change Details.
In the downloaded file, you will see that the process variant type was changed, for example from 527 to 547 when changing from bidirectional to inbound only.
Keywords
contract, communication arrangement, document type, pricing, inbound, bidirectional, Pricing failed, no receiver system, Check communication arrangement, Saved replicated contract cannot be saved if pricing is not calculated, Contract not transferred to ERP. Please request external pricing update , KBA , LOD-LE-COP , Contract Processing , How To