SAP Knowledge Base Article - Public

3425395 - After enabling the Onboarding Real Time Sync, Onboarding Users are not visible in IAS

Symptom

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors HCM suite

Reproducing the Issue

In the IAS Admin Console

  1. Go to User Management
  2. Search for the Onboarding user.
    No information or user is showing

In the Data Inspector Tool 

  1. Go to Data Inspector Tool
  2. Select Table_User_Account
  3. Search for the affected users/user
  4. Check the Extension Status
    The status is 0, which means users are successfully synced.

In Execution Manage Dashboard

  1. Go to SuccessFactors Instance
  2. In the Admin Center, search Execution Manager 
  3. Select Pre-delivered integrations
  4. Check the date range for Real-time Sync
  5. Check if the Process State is Completed Successfully.

In IPS, the sync job was successful.

Cause

Possible causes can include:

  1. IPS tenant not migrated yet to SAP Cloud Identity Infrastructure from the SAP BTP, Neo environment.
  2. User data inconsistency - such as email not valid, etc
  3. Wrong system ID entered in the Destination URL in Integration Service Registration Center page in SuccessFactors

Resolution

To identify which of the causes are impacting your system, please follow the steps below:

Cause #1: 

To identify what type of Identity Provisioning tenant environment you have, refer to this KBA 3171247 - How to tell which infrastructure an Identity Provisioning tenant is running on.

Note that: The Real Time Sync may have an intermittent success rate outcome. Although a successful sync is possible, there may be issues encountered. Therefore, our engineering team recommends the migration of the IPS tenant to SAP Cloud Identity Infrastructure, as stated in this help guide Manage Real-Time Sync of New Hires from SAP SuccessFactors to Identity Authentication with Identity Provisioning.

Cause #2:

If the Execution Manager Dashboard shows "Completed Successfully, check the event details and copy the Business Key. 

Then, go to IAS > Identity Provisioning > Provisioning Logs > and select the Real-Time Provisioning Execution Logs. In this page, search for the Business Key and check if the sync was successfully or not. If not, check the failure details to any data inconsistency error and correct the user from Onboarding side. 

Cause #3:

If there aren't failures in the IPS Real-Time Provisioning Execution Logs, check the system ID information following steps below:

  1. In SuccessFactors, search for Integration Service Registration Center > select Identity Provisioning > Check the Destination URL. 
  2. At the end of the URL, the number needs to match the SuccessFactors Source System ID (check the sample of our internal demo system below)

NOTE: If you use the ID from a different source (i.e. Joule source system), the sync will be successful, but point out to a different target, hence the user won't be synced to IAS. 

See Also

Keywords

Not synced to IAS, Onboarding , New users, IPS , IAS ,  Manage Real-Time Sync of New Hires from SAP SuccessFactors to Identity Authentication with Identity Provisioning,, Migrate Identity Provisioning Bundle Tenants , IPS, Real time sync , Onboarding sync , BTP , NEO , SAP Cloud identity , Onboarding users , KBA , LOD-SF-PLT-IAS , Identity Authentication Services (IAS) With BizX , LOD-SF-OBX-IAS , IAS User Authentication , BC-IAM-IPS , Identity Provisioning Service (IPS) , Problem

Product

SAP SuccessFactors HCM Core all versions