SAP Knowledge Base Article - Public

3425431 - Error when trying to manually create the E-verify activity - Onboarding 1.0

Symptom

Receiving the following message error when trying to initiate the E-verify:

  • An error has occurred.
  • Please return to the home page to continue accessing your account. If the error still appears, close the browser and re-start Onboarding 1.0. Error timestamp: [Timestamp ID].

Environment

SAP SuccessFactors Onboarding 1.0

Cause

  • From the Super Admin, there is no value for the SSN key (I9SocialSecurityNumber) populated.
  • As there is no value provided for the SSN (Social Secure Number), this indicates that or the candidate did not provided the Social Secure Number or the value was with invalid characters.

Resolution

For Live Customer(s):  

As per the information in the E-Verify guidelines:

"A case cannot be created in E-Verify without an SSN. If a newly hired employee has applied for, but has not yet received his or her SSN (e.g., the employee is a newly arrived immigrant), attach an explanation to the employee’s Form I-9 and set it aside. 

Then you would need to create a case to E-Verify using the employee’s SSN as soon as it is available. 

If you are unable to create a case by the third business day after the employee’s first day of employment, select Awaiting Social Security number when prompted by E-Verify.

Kindly check this with the Implementation SAP Partner or SAP Product Support to add the SSN value in Super Admin.

Based on the E-Verify Guidelines, it's only possible to create a new E-Verify activity when the candidate's SSN is available.

For SuccessFactors Onboarding Support, Implementation Partner(s) and Consultant(s):

  1. Go to Super Admin
  2. Manage HRData > Search for the affected candidate
  3. Search the SSN Key (I9SocialSecurityNumber)
  4. Update the SSN value with the correct value
  5. Save the changes and after that try to initiate the E-verify for the candidate again

Keywords

E-verify, OBD, SSN, format, System.Web.HttpUnhandledException, manually, initiate, I9SocialSecurityNumber, I9, Social, Secure, Number , KBA , LOD-SF-OBD-EVF , e-Verify , Problem

Product

SAP SuccessFactors Onboarding all versions