SAP Knowledge Base Article - Public

3425603 - The condition in Advanced Search is not working

Symptom

You are using the Including or Excluding conditions in Advanced Search, but the excluded records displayed in the list or included records missed in the list.

Environment

SAP Cloud for Customer

Reproducing the Issue

Issue can be raised in any work center views, take Account Work Center View as an example.

  1. Go to Customers work center.
  2. Go to Accounts work center view.
  3. Select and go to impacted Query.
  4. The Query set with condition a). EXCLUDING "Field A = Value a" and condition b). INCLUDING "Field B = Value b".
  5. The expected behavior is all "Field A = Value a" records do not displayed in the list, but still has "Field A = Value a" records in the list.

 

Cause

This is an expected behavior. The logic of conditions in Advanced Search is, conditions will work together. EXCLUDING "Field A = Value a" and INCLUDING "Field B = Value b" means remove the result of "Field A = Value a", but if exist "Field B = Value b" in results, the records with "Field B = Value b" will be reserved.

Resolution

You can get the expected results by creating multiple queries. Or, you can use the filter of the column in the list.

Keywords

Advanced Search, including, excluding, conditions, query, filter , KBA , LOD-CRM-ACC , Account , AP-RC-UIF-FLX , Page Layout & Key User Configuration , Problem

Product

SAP Cloud for Customer core applications all versions