Symptom
- Form checkbox behavior is inconsistent with value collected in Additional Data Collection step.
- ADC fields are not always being mapped to the custom form checkboxes - e.g. after changing some picklist value in ADC, all checkboxes in form are no longer working.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Initiate onboarding for candidate 1
- Complete ADC with certain value
- Check the form generated by DocuSign >> checkboxes are correctly mapped
- Initiate onboarding for candidate 2
- Complete ADC and change some value of the picklist (e.g. change "Yes" to "No"; add new records with new picklist value, etc.)
- Check the form generated by DocuSign >> checkboxes are all empty and no value is mapped
Cause
In Manage Data >> Onboarding data collection configuration, more than 1 "List of UI Items Configurations" are configured under one same custom MDF object.
It's not supported to configure multiple UI Items Configuration under 1 Custom_Data_Collection configuration MDF object. This results in the data being overwritten as rule is picking up incorrect object and hence unable to resolve the data properly.
Resolution
For Additional Data Collection, please create 1 custom MDF object under "Onboarding data collection configuration" for each UI Items Configuration.
Keywords
Additional Data Collection, Custom Data Collection, ADC, CDC, mapping, checkbox, form, DocuSign , KBA , LOD-SF-OBX-CDC , Custom Data Collection , Problem