Symptom
Error 'Acct &: Stmnt & opening bal.is not the same as stmnt & closing bal.' is received when bank statements are uploaded for new calendar year.
Environment
SAP S/4HANA Cloud
Reproducing the Issue
Upload bank statement files via App Manage Incoming Payment Files or via MBC.
Cause
Balance check is always done based on the bank statement number (and not based on the bank statement date) and statements should be uploaded in a chronological order which suits with the statement number. So for the first statement of the new year, the system selects the statement with the highest statement number from the previous year and compares this balances.
The balance check can only work if the numbering of the statements is consecutively. When the statement nr X is imported, the system checks, if there is a statement nr X-1. If the statement was already imported, there is a balance check. If not, there is no balance check.
In that case and if the closing balance of the preceding statement is not the same as the opening balance of the current, error "Acct &: Stmnt & opening bal.is not the same as stmnt & closing balance" could be issued.
Resolution
Post bank statements in chronological order. For that ask the bank to send the statements in the correct sorting order without skipping any statement number in the future.
For temporary solution please check KBA 3423072 Error message "Acct & &: Stmnt & opening bal.is not the same as stmnt & closing bal."
See Also
3423072 Error message "Acct & &: Stmnt & opening bal.is not the same as stmnt & closing bal."
Keywords
opening balance, closing balance, mismatch, chronological, year end change, FB772, FEBKO-AZIDT, FB 772, bank statement, Manage Incoming Payment Files, F1680, F1 680 , KBA , FI-BL-PT-BA-2CL , bank statement (Public Cloud) , Problem